Skip to content

Menus

The various features in LightBurn are accessed through the menus. The various features in each menu are listed and explained here.


File Menu

New

Clicking "New" in the File Menu will clear any current project and create a new one. You can also press Ctrl+N / Cmd+N.

Recent Projects

This will open a list of the most recently opened files to choose from.

Open

To open an existing or saved file, click on “Open” in the File menu or press Ctrl+O / Cmd+O.

Import

You can import any supported LightBurn files into the file you are currently working on. Click on “Import” in the File menu or press Ctrl+I / Cmd+I LightBurn supports importing the following file types: svg, ai, pdf, dxf, hpgl, plt, png, jpg, bmp, tiff, gif, webp.

Show Notes

Add or view project comments through this menu. (Ctrl+Alt+N)

Save

To save a project click on “Save” in the File menu or press Ctrl+S / Cmd+S. Type the name you want the file saved as in the dialog box that opens up.

Save As

To save a file with changes, but still keep the original file intact, click on the “Save As” icon in the File menu.

Save GCode

Generates and saves the GCode (the code that gets would normally be sent to the laser cutter) for the project as it currently stands. This option will only be enabled for devices that communicate via GCode. (Alt+Shift+L)

Export

To export a file to a different file format, click on “Export” in the File menu (Ctrl+X / Cmd+X). LightBurn can export to SVG, AI, and DXF formats. Bitmaps are only exported in SVG files, and text is automatically converted to simple shapes in all export formats.

If you have objects selected, only those will be exported, otherwise it will export the entire content of your project. If you have exactly one bitmap selected, you will also be given the option to export as PNG or JPG.

This menu item (Ctrl+P) outputs a black and white document to be sent to a printer or built-in "Print to PDF" tools. This document is saved exclusively in black/white.

Similarly to above, you can use Print (keep color) to send to a physical printer, or to a file, your design for review, markup, etc. The export is sent with the same colors as selected in the [Color Palette]. This can also be triggered by Ctrl+Shift+P.

Save Processed Bitmap

Exports a copy of a bitmap that you have edited in LightBurn with the edits.

Save Background Capture

If you have a camera connected, this function saves a screenshot of the camera feed.

Open prefs folder

Opens the folder containing your LightBurn preferences in your file browser.

Export Prefs

Allows you to export your preferences as they currently stand.

Import Prefs

Allows you to import preferences from an exported copy.

Load Prefs Backup

Allows you to import preferences from a list of (automatically saved) versions.

Exit

To exit LightBurn, click on the “Exit" in the File menu or press Ctrl+Q / Cmd+Q. You will be prompted to save your file if you have unsaved changes.

Return to top


Edit Menu

Undo

To undo the last editing action done on the current file, click on "Undo" in the Edit menu or press Ctrl+Z / Cmd+Z

Redo

To Redo the last editing action done on the current file, click on "Redo" in the Edit menu or press Shift+Ctrl+Z / Shift+Cmd+Z

Select all

To select all objects in the current file click on "Select all" in the Edit menu or press Ctrl+A / Cmd+A.

Invert Selection

Selects the opposite of what you have currently selected. E.g. if you have one object selected, it will select every object except that one.

Cut

To one or more objects from the current file, select them and click on "Cut" in the Edit menu or press Ctrl+X This will put the object on the clipboard, and remove it from the current file.

Copy

To copy one or more objects, select them and click "Copy" in the Edit menu or press Ctrl+C / Cmd+C This will put the objects on the clipboard, but leave the original object alone.

Duplicate

To duplicate a selection in place, select one or more objects and click "Duplicate" in the Edit menu or press Ctrl+D. This is an "in-place" copy and paste operation all in one, bypassing the clipboard. This means if you already have something on the clipboard, it'll still be there after using Duplicate. The duplicate is placed directly on top of the original.

Paste

To paste an object from the clipboard click "Paste" in the Edit menu or press Ctrl+V. This will place a copy of the clipboard contents in the current file. Note that LightBurn can paste text or images copied to the clipboard from other software.

Paste in place

To paste an object from the clipboard click "Paste in place" in the Edit menu or press Alt+V. This will place a copy of the clipboard contents in the current file in the same spot that it was in the original file.

Delete

To delete an object select it and click "Delete" in the Edit menu, or hit Del. This will remove the object from the current file.

Convert to path

This converts a built-in shape object, like a rectangle, ellipse, or text, into lines and curves that can be edited. Click on "Convert to path" in the Edit menu. The original shape information is lost, so you won't be able to change text with the text tool after using this.

Convert to Bitmap

This converts selected vectors into bitmaps (rasters/pixels).

Close path

In order to Fill a shape with your laser, the shape must be a closed loop, where the starting and ending point are the same. If the start and end points are very close, but not quite connected, "Close Path" will move them together. Click on "Close path" in the Edit menu or press Alt+C.

Close paths with tolerance

Works similarly to close paths, but allows you to set a tolerance for "close" points, so that it doesn't join parts that are far from each other.

Auto join selected shapes

Looks at the start and end points of all the selected curves, and if any of them are close enough, connects them together into a single shape. Useful when importing DXF files, which don't contain connectivity information. Click on "Auto join selected shapes" in the Edit menu or press Alt+J

Optimize Selected Shapes

Attempts to fit the selected shapes to arcs and lines within a specified error tolerance. Useful for reducing the point count in a shape, or recovering arcs from software that exports them as many small line segments.

Delete Duplicates

This will delete duplicate items within the drawing, for example if two squares are identical and one on top of the other, this will delete the extra square. This helps to minimize erroneous moves and double-cuts.

Select Open shapes

This will select all open shapes in the document.

Select open shapes set to fill

This will select all the open shapes that are set to fill in the document.

Select all shapes in current layer

This will select all the shapes that are set to cut in the current layer of the document. Note that if some of these shapes are grouped, the system may have to un-group them in order to select them.

Select contained shapes

Will select all the shapes that fall entirely within the shape you have selected.

Image Options

Offers you various ways to refresh or replace bitmap images in your project. Handy if you have made some edits to a bitmap in a different editing software, and you want to replace the old version you have open in LightBurn.

Settings

Clicking on "Settings" in the Edit menu will open the Settings window, where you can change general user settings and preferences.

Device Settings

Opens the Device Settings window, for editing LightBurn preferences specific to the chosen laser.

Machine Settings

Opens an editor that allows reading and writing firmware settings from supported controllers.

Debug drawing

This is mostly an internal tool for LightBurn developers that shows the bounds of shapes being drawn.

Convert to cut

Also an internal tool for LightBurn developers - It converts the selected shapes into the cuts that would be sent to the laser, and makes a new shape from the result. This is not how you produce gcode / cuts for your machine, it's just a debugging tool for the LightBurn developers.

Return to top


Tools Menu

Many of the tools in this menu are also available as icons in the tool toolbar that by default, is on the left side of the workspace. See Creation Tools for more information.

Select

Click on "Select" to select objects in the workspace, or to access menus and toolbars.

Draw Lines

Click on "Draw Lines" or press Ctrl+L to draw straight or curved lines in the workspace. Click + Drag to make curved lines.

Rectangle

Click on "Rectangle" or press Ctrl+R to draw rectangles in the workspace.

Ellipse

Click on "Ellipse" or press Ctrl+E to draw ellipses in the workspace.

Polygon

Create a regular polygon with a variable number of sides (triangle, hexagon, octagon, etc). (Shift & drag)

Edit Nodes

Click on "Edit Nodes" or press ++ctrl+~++ to edit nodes of objects in the workspace.

Edit Text

Click on "Edit Text" or press Ctrl+T to create or edit text in the workspace.

Position Laser

Allows you to click on a place in your project, and have your laser move to that point in real life (works best with absolute coordinates/end-stops).

Measure

Opens up a window that provides you with various information about objects as you hover over them in your scene. Things like line length, start and end point, etc.

Create QR Code

Allows you to create a QR code containing various information such as: Wifi details, contact info, links, text, raw content, etc.

Offset Shapes

Used to create new shapes that are offset from the current selection, inward or outward.

Weld Shapes

Fuses multiple shapes together into a single outline.

Boolean Union

Adds two closed paths together into one mass so that all their intersecting lines disappear.

Boolean Difference

Select an closed path you want cut, and then also select another that you want to cut out of the first and then click Boolean Difference to do so.

Boolean Intersection

Select two closed paths and click Boolean Intersection to remove all the areas that don't overlap.

Boolean Assistant

Gives you a preview of the Boolean functions described above, to help you choose the correct one.

Cut Shapes

Select the shape you want cut and also select another shape, then select Cut Shape. The outcome will both what you would get from a boolean difference and a boolean intersection. This also works on open paths (unlike the boolean operations).

Adjust Image

Allows you to edit a bitmap image in various ways, such as brightness, contrast, image processing mode, negative, etc.

Trace Image

Opens a dialog box where you can trace the content of a bitmap image into vector graphics. (Read more here)

Apply Path to Text

If you select a shape and a line of text, this command will attach the text to the shape, so the text follows the path. (Read more here)

Apply Mask to Image

Select a closed shape and a bitmap, and this function will cut the bitmap to fit the shape.

Return to top


Arrange Menu

Group

Click on "Group" or press "Ctrl + G" to group the selected objects in the workspace.

Ungroup

Click on "Ungroup" or press "Ctrl + U" to ungroup the selected objects in the workspace.

Auto-Group

Automatically groups shapes within other shapes that contain them.

Flip Horizontal

Click on "Flip Horizontal" or press "Ctrl + Shift + H" to flip the selected objects in the workspace horizontaly.

Flip Vertical

Click on "Flip Vertical" or press "Ctrl + Shift + V" to flip the selected objects in the workspace vertically.

Mirror Across Line

Select objects and the shift select line to mirror them about, and then click "Mirror Across line" or press "Alt+M".

Rotate 90° Clockwise

Select objects and click "Rotate 90° Clockwise" or press ".".

Rotate 90° Counter-Clockwise

Select objects and click "Rotate 90° COunter-Clockwise" or press ",".

Two-Point Rotate / Scale

Select object and click "Two-Rotate / Scale " or press "Ctrl/CMD + 2". Click the point you will rotate about, then to only rotate, move the mouse to the second point. To scale hold shift while rotating. For more information see Two-Point Rotate / Scale

Align Centers

Click on "Align Centers" to place the center points of the selected objects directly on top of each other.

Align Left

Click on "Align Left" or press "Ctrl + Shift + Left arrow" to align the selected objects in the workspace to the left.

Align Right

Click on "Align Right" or press "Ctrl + Shift + Right arrow" to align the selected objects in the workspace to the right.

Align Top

Click on "Align Top" or press "Ctrl + Shift + Up arrow" to align the selected objects in the workspace to the top.

Align Bottom

Click on "Align Bottom" or press "Ctrl + Shift + Down arrow" to align the selected objects in the workspace to the bottom.

Align H-Center

Click on "Align H-Center" to align the selected objects in the workspace to the center of the horizontal plane.

Align V-Center

Click on "Align V-Center" to align the selected objects in the workspace to the center of the vertical plane.

Distribute

Provides various methods of evenly spacing objects across various axes.

Move H-together

Click on "H-together to move shapes like distribute, but keeps shapes together

Move V-together

Click on "V-together to move shapes like distribute, but keeps shapes together

Nest Selected

Exports selected objects to a file, copies that file path, and opens SVGnest.com so you can upload the file and nest your objects.

Dock

A little like simple nesting. Select some shapes and click one of the directional docking buttons, and LightBurn will "dock" all your shapes together in that direction, moving them together until they touch. See Docking for more information.

Move Selected Objects

Offers various places to move the selected objects to, such as page centre, laser position, upper left, etc.

Move to Page Center

Click on this to move selected objects to center of page

Move to Upper Left

Click on this to move selected objects to Upper Left of page.

Move to Upper Right

Click on this to move selected objects to Upper Right of page.

Move to Lower Left

Click on this to move selected objects to Lower Left of page.

Move to Lower Right

Click on this to move selected objects to Lower Right of page.

Move Laser to Selection

Offers various ways for you to move the laser to parts of the object you have selected, like the top left or centre of it.

Grid / Array

Click on "Grid / Array" to create an array or grid of objects in the workspace. A window will open allowing you to enter the parameters for the array or grid. For more details, see here.

Circular Array

Click on "Circular Array" to create an array or grid of objects in a circle in the workspace. A window will open allowing you to enter the parameters for the array. For more details, see here.

Copy Along Path

Click on "Copy along Path" to create a set of copies of your selected shapes along a path. The path is the last object you select, and the shapes will be copied relative to the first point in the path object.

Create Rubber-Band outline from selection

Creates an outline on the current layer encompassing all selected parts.

Break apart

Click on "Break apart" to break selected object into individual parts.

Push forward in draw order

Click on "Push forward in draw order" or use "Page up" key to move the selected object up one level in the draw order. Usefull when trying to see objects on the screen.

Push backward in draw order

Click on "Push backward in draw order" or use "Page down" key to move the selected object down one level in the draw order. Usefull when trying to see objects on the screen. "Ctrl-PgDn" or "Ctrl-PgUp" will send an object to the very bottom, or very top of the objects on the screen.

Push to Front

Moves the selected object to the top of the drawer order.

Push to Back

Moves the selected object to the bottom of the drawer order.

Note: Drawing order changes only work in wireframe (outline) rendering mode, not filled. In filled rendering mode, the display order will always match the layer order.

Lock Selected Shapes

Locks selected shapes from being edited in any way.

Unlock Selected Shapes

Unlocks selected shapes to allow them to be edited again.

Return to top


Laser Tools Menu

The Laser Tools menu is the new home for utilities that interact with the laser.

This sub-menu lets you run the Print and Cut wizard, set the targets, enable the different Print and Cut modes, or reset it.

Calibrate Camera Lens

Open the camera lens calibration wizard. For more information on setting up the camera, see here.

Calibrate Camera Alignment

Open the camera alignment calibration wizard. For more information on setting up the camera, see here.

Rotary Setup

This will open the rotary setup dialog box. Use this to set up your rotary attachment.

Feeder Setup

This will open the auto-feed setup dialog. Use this to set up the auto-feed table controls for Ruida controllers with an auto-feeding table.

Focus Test

Opens the Focus Test generator tool. Requires a machine with a controlled Z-axis.

Interval Test

Opens the Interval Test generator tool, though this has been largely replaced by the Material Test generator below.

Material Test

Opens the Material Test generator tool, which lets you generate and run test grids with varying settings.

Center Finder

Opens the Center Finder tool, used to locate the center of a circular object in a few simple steps. see Center Finder


Window Menu

Reset to Default Layout

To arrange the windows and menus back to the original default layout, click on "Reset to Default Layout" You can use the Window menu to toggle windows and menus on or off.

Preview

Click on "Preview" or press "Alt + P" to open the preview window. It will show the current laser project and includes information on cut distance, rapid moves, and total time estimate. Cut lines are in black and traversal moves are red. You can toggle the display of traversal moves on or off, as well as shading by power level.

Zoom to Page

Zooms so that the full workspace is in view.

Zoom In

Click on "Zoom In" or press "Ctrl + =" to zoom in the workspace.

Zoom Out

Click on "Zoom In" or press "Ctrl + -" to zoom out in the workspace.

Frame Selection

Zoom the view to completely contain the current selection. (Ctrl + Shift + A)

View Style

Allows you to change the appearance of objects in your scene from wireframe or filled modes.

Return to top


Language Menu

Choose the language you would like to have LightBurn use in this menu.

Return to top


Help Menu

About LightBurn

Shows your LightBurn Version, copyright and attribution information.

LightBurn Support Forum

Links to our online forum where you can get help from our support staff and the community.

Quick Help and Notes

Click on "Quick Help and Notes" or press F1 to access hotkey list, general usage notes and version information.

Online Documentation

Click on "Online Documentation to access the documentation for LightBurn.

PDF Documentation

Links to a PDS copy of our documentation, if you prefer reading pages over online text.

Online Video Tutorials

Click on "Online Video Tutorials" to access the tutorial videos.

CorelDraw macro setup help

Links to documentation about installing the LightBurn macro for CorelDraw

Generate Support Data

Generates encoded data that is handy to provide to our support staff when you are seeking help with a problem.

Camera Selection Help

Helps you select an apropriate camera for your laser cutter.

Check for Updates

Click on "Check for Updates" to make sure you are on the most recent version.

License Management

Launch the license dialog, where you can enter your license key, or see the status of your trial period or license.

Enable Debug Log

This is for the developers, turn on the log by clicking on "Enable Debug Log". The log file will be written to your "My Documents" folder on Windows, or Documents on Mac, and is cumulative - each time you enable the debug log it will append to any existing log, so it's a good idea to delete it after you're finished.

Return to top